Негізгі сертификаттар

ҰКО (RSA_OLD) pki_rsa
ҰКО (GOST_OLD) pki_gost
НКО (RSA) root_rsa
НКО (GOST) root_gost
ҰКО (RSA) nca_rsa
ҰКО (GOST) nca_gost

Кері шақырылған сертификаттардың тізімі

ҰҚО (RSA_OLD) CRL Delta CRL
ҰҚО (GOST_OLD) CRL Delta CRL
ҰҚО (RSA) CRL Delta CRL
ҰҚО (GOST) CRL Delta CRL

ЭЦҚны қайта шығарғыңыз келе ме? бөлімге өту >>

Welcome, Guest
Username Password: Remember me

TOPIC: Установка Java и NCA Layer.

Установка Java и NCA Layer. 4 months ago #4936

  • dooons
  • OFFLINE
  • Осваиваюсь на форуме
  • Posts: 22
  • Karma: 0
Всем здравствуйте! ОС Ubuntu 19.04 Gnome 3.32.0

И так, вопрос №1.
Как установить Java? Какую версию нужно устанавливать?

Вопрос №2.
Как установить сам NCA Layer?

Установил по инструкции... Все прошло хорошо, но в последний момент выскакивает сообщение
" Не удалось запустить NCALayer.
Activator start error in bundle kz.gov.pki.api.layer.NCALayerServices
Подробности в файле логирования /home/dooons/.config/NCALayer/ncalayer.log@

Как устранить такую ошибку?

ВАЖНО! Мы работники школы, нам нужно заполнить Национальную образовательную базу данных. Без этой программы туда не зайти.

Re: Установка Java и NCA Layer. 4 months ago #4937

  • dooons
  • OFFLINE
  • Осваиваюсь на форуме
  • Posts: 22
  • Karma: 0
Вот версия установленная на моем ноутбуке


dooons@dooons-Aspire-E5-576G:~$ java -version
java version "11.0.2" 2019-01-15 LTS
Java(TM) SE Runtime Environment 18.9 (build 11.0.2+9-LTS)
Java HotSpot(TM) 64-Bit Server VM 18.9 (build 11.0.2+9-LTS, mixed mode)

dooons@dooons-Aspire-E5-576G:~$ javac -version
javac 11.0.2
Last Edit: 4 months ago by dooons.

Re: Установка Java и NCA Layer. 4 months ago #4938

  • dooons
  • OFFLINE
  • Осваиваюсь на форуме
  • Posts: 22
  • Karma: 0
При попытке установить OpenJFX показывает вот это. Думаю у меня установлен OpenJFX.

dooons@dooons-Aspire-E5-576G:~$ sudo apt-get install openjfx
[sudo] пароль для dooons:
Чтение списков пакетов… Готово
Построение дерева зависимостей
Чтение информации о состоянии… Готово
Уже установлен пакет openjfx самой новой версии (11.0.2+1-1).
Следующие пакеты устанавливались автоматически и больше не требуются:
ca-certificates-java fonts-dejavu-extra libatk-wrapper-java
libatk-wrapper-java-jni libice-dev libpthread-stubs0-dev libsm-dev
libx11-dev libxau-dev libxcb1-dev libxdmcp-dev libxt-dev x11proto-core-dev
x11proto-dev xorg-sgml-doctools xtrans-dev
Для их удаления используйте «sudo apt autoremove».
Обновлено 0 пакетов, установлено 0 новых пакетов, для удаления отмечено 0 пакетов, и 2 пакетов не обновлено.

Re: Установка Java и NCA Layer. 4 months ago #4941

  • ololo
  • OFFLINE
  • Живу я здесь
  • Posts: 464
  • Karma: 57
Добрый день. На данный момент NCALayer не поддерживает модульную архитектуру java11.
Рекомендуем установить 8 версию www.java.com/en/download/manual.jsp
gg wp

Re: Установка Java и NCA Layer. 4 months ago #4942

  • dooons
  • OFFLINE
  • Осваиваюсь на форуме
  • Posts: 22
  • Karma: 0
Попытка установить Ява8 не заканчивается успехом. При добавлении репозитория говорит что пакеты не найдены. Позже приведу пример установки.

Re: Установка Java и NCA Layer. 4 months ago #4943

  • ololo
  • OFFLINE
  • Живу я здесь
  • Posts: 464
  • Karma: 57
а вы не с репозитория ставьте, а с targz архива на сайте Oracle
инструкция к установке тут указана
www.java.com/en/download/help/linux_x64_install.xml#install
gg wp
Time to create page: 0.20 seconds
FaLang translation system by Faboba