Негізгі сертификаттар

ҰКО (RSA_OLD) pki_rsa
ҰКО (GOST_OLD) pki_gost
НКО (RSA) root_rsa
НКО (GOST) root_gost
ҰКО (RSA) nca_rsa
ҰКО (GOST) nca_gost

Кері шақырылған сертификаттардың тізімі

ҰҚО (RSA_OLD) CRL Delta CRL
ҰҚО (GOST_OLD) CRL Delta CRL
ҰҚО (RSA) CRL Delta CRL
ҰҚО (GOST) CRL Delta CRL

ЭЦҚны қайта шығарғыңыз келе ме? бөлімге өту >>

Welcome, Guest
Username Password: Remember me

Проблема с dependency в примере NCALayer модуля
(1 viewing) (1) Guest
  • Page:
  • 1
  • 2

TOPIC: Проблема с dependency в примере NCALayer модуля

Проблема с dependency в примере NCALayer модуля 1 year, 1 month ago #4166

  • Kuyubaev
  • OFFLINE
  • Новый участник
  • Posts: 18
  • Karma: 0
Здравствуйте!

При попытке собрать пример модуля для NCALayer возникла проблема с dependency
<dependency>
<groupId>kz.gov.pki.provider</groupId>
<artifactId>knca_provider_util</artifactId>
<version>0.4.0-SNAPSHOT</version>
<scope>provided</scope>
</dependency>

Думал для этого нужно импортировать kalkancrypt-0.4.jar в локальный Maven repository. Для этого использовал строку:
mvn install:install-file -Dfile="C:\Users\y.kuyubayev\Downloads\Kalkan SDK2 (2018-05-18)\SDK 2.0\NCALayer\bundle_sample\kalkancrypt-0.4.jar" -DgroupId=kz.gov.pki.kalkan -DartifactId=knca_provider_jce_kalkan -Dpackaging=jar -Dversion=0.4

Инфу по artifactId, groupId, version нашел внутри самого jar архива kalkancrypt-0.4.jar.

Установка прошла успешно, но проблема с dependency не прошла.

Способ рабочий, потому что таким же образом решил проблему с dependency
<dependency>
<groupId>kz.gov.pki.osgi.layer.api</groupId>
<artifactId>BundleServiceAPI</artifactId>
<version>1.0-SNAPSHOT</version>
<scope>provided</scope>
</dependency>
Там все прошло успешно и проблема устранилась. Но с первой проблемой такое не помогло.

В чем ошибка? И как можно решить проблему?

Re: Проблема с dependency в примере NCALayer модуля 1 year ago #4171

  • Kuyubaev
  • OFFLINE
  • Новый участник
  • Posts: 18
  • Karma: 0
Или по другому - с какой библиотекой связана данная зависимость

<dependency>
<groupId>kz.gov.pki.provider</groupId>
<artifactId>knca_provider_util</artifactId>
<version>0.4.0-SNAPSHOT</version>
<scope>provided</scope>
</dependency>

Думал kalkancrypt, даже установил его в локальный MavenRepo, но не то по ходу.

Если я правильно понимаю, то в этой библиотеке должен быть пакет kz.gov.pki.provider, но в Kalkancrypt-0.4.jar такого нет.

А если эту зависимость вообще убрать? Она нужна если я собираюсь работать с сертами?

Re: Проблема с dependency в примере NCALayer модуля 1 year ago #4184

  • margulan
  • OFFLINE
  • Модератор
  • Posts: 157
  • Karma: 12
На данный момент этой библиотеки нет в SDK. Ее необязательно использовать.
The following user(s) said Thank You: Kuyubaev

Re: Проблема с dependency в примере NCALayer модуля 1 year ago #4191

  • Kuyubaev
  • OFFLINE
  • Новый участник
  • Posts: 18
  • Karma: 0
Сейчас вроде немного вник в разработку модулей для NCALayer, но не могу разобраться с несколькими вопросами.

1) Если наш bundle должен иметь 2 метода, то он должен содержать две реализации интерфейса ModuleService?
Т.е. пусть нам нужно два метода: sign и verify
То мы должны реализовать что-то наподобие

public class SignServiceImpl implements ModuleService {
..
}

и

public class VerifyServiceImpl implements ModuleService {
...
}

Правильно ли я понимаю?

Или же реализация интерфейса ModuleService одна. А уже внутри его метода process(...) мы анализируем параметр "method" json строки и вызываем нужный метод?

2) Для целей тестирования: Я отправляю вам сертификат подписи кода (тестовый) и Bundle-SymbolicName, получаю от вас ncalayer.der, устанавливаю bundle на своем NCALayer (локально).
Затем, получается, я могу вносить изменения в bundle по своему усмотрению без повторных обращений к вам? (До момента выпуска официальной версии разумеется.)

3) Какие данные указать в электронном письме помимо сертификата подписи кода и Bundle-SymbolicName для тестовых целей? Например, организация, телефон, ФИО адресата и тому подобные данные нужны?

4) Подписание бандла самоподписным сертом вроде проходит без ошибок.
При попытке загрузки в NCALayer в логе выдает "No symbolicName or unpermitted bundle!". Т.е. остается получить ncalayer.der как я понимаю?
Сертификат подписи кода и Bundle-SymbolicName высылать на адрес This email address is being protected from spambots. You need JavaScript enabled to view it. ? Это все пока в тестовых целях.

5) Тут в одной из тем форума, где обсуждается разработка модулей, приводится ссылка на кусок кода:

ServiceTracker<NCALayerService, NCALayerService> ncaLayerService_tracker = new ServiceTracker(context, context.createFilter(filter), null);
ncaLayerService_tracker.open();
ncaLayerService = ncaLayerService_tracker.getService();

В примерах Kalkan SDK от 5 мая я этого не вижу. Откуда они взяли это?


Заранее спасибо!
Last Edit: 1 year ago by Kuyubaev.

Re: Проблема с dependency в примере NCALayer модуля 1 year ago #4206

  • ololo
  • OFFLINE
  • Живу я здесь
  • Posts: 459
  • Karma: 57
Здравствуйте!

1) Вам нужно реализовать один раз ModuleService и в process уже обрабатывать что-угодно и как хотите. Это небязательно может быть параметр "method". Полностью на ваше усмотрение.
2) Все верно.
3) Укажите данные организации, ФИО, телефон. Укажите также начальную версию, с которой вы начнете отсчет, типа 0.0.1, 0.1, 1.0 . В дальнейшем при обновлениях будете повышать версию.
4) Да, без ncalayer.der не получится запустить.

Можете еще для ознакомления посмотреть исходники CommonBundle
gg wp
The following user(s) said Thank You: Kuyubaev

Re: Проблема с dependency в примере NCALayer модуля 1 year ago #4227

  • Kuyubaev
  • OFFLINE
  • Новый участник
  • Posts: 18
  • Karma: 0
Здравствуйте!

Файл ncalayer.der получил. Модуль установился. Пример работает прекрасно. Спасибо.

Теперь возникла следующая проблема - при попытке встроить подписание xml из java примеров в свой модуль выдает ошибку:

2018-07-04 18:13:06 ERROR [java.lang.Throwable] - Exception in thread "NanoHttpd Request Processor (#1)" java.lang.NoClassDefFoundError: javax/xml/transform/dom/DOMSource.

В osgi.properties указываю

Import-Package=org.json,\
org.w3c.dom,\
org.apache.xml.security.exceptions,\
org.apache.xml.security.signature,\
org.apache.xml.security.transforms,\
javax.xml.transform.dom,\
kz.gov.pki.kalkan,\
...

Самое интересное, что такая же ошибка была с org.apache.xml.security.signature, но после того как сходил на перекур она самоустранилась. Мистика просто какая-та.

С javax.xml.transform.dom перекур не помог))

В чем может быть дело?
  • Page:
  • 1
  • 2
Time to create page: 0.22 seconds
FaLang translation system by Faboba